#linux

Mount Synology HDD under Linux

My Synology DS214Play failed last week, and I replaced it with a QNAP TS-453A. However, as they use incompatible software the first thing that the QNAP wanted to do was erase my disks. I thought …

TP-Link TL-WN823N on Arch Linux

Unfortuntately, Arch doesn't support the TP-Link TL-WN823N by default, so you have to install the drivers by hand.

Error while loading shared libraries: libbz2.so.1.0: cannot open shared object file on CentOS 7

Whilst trying to build using electron-builder on CentOS 7, I ran into the following error message:

Connecting to a hidden network on Arch Linux

If you're using netctl to manage your network connections on Arch and need to connect to a hidden wireless network, make sure that you have Hidden=yes in your config file e.g.

Yubikey on Arch

Just a quick guide how to get a Yubikey working on Arch Linux.

YouCompleteMe on Arch Linux

After upgrading YouCompleteMe recently, it stopped working. My first thought was that the libraries needed rebuilding:

Arch Linux: netctl and vpnc (Cisco VPN)

This is an example of how to connect to a Cisco VPN using netctl on Arch Linux.

Running gpg-agent on Ubuntu

I recently made it so that all my git commits are automatically signed by my GPG key (yay!), but typing my passphrase for every commit got old very quickly.

Build CentOS 5 generic RPM on CentOS 6

I've been trying to build a generic RPM (PHP code only, nothing linked) that installs on CentOS 5 and CentOS 6. We used to do this on CentOS 5, but when we moved our build box to CentOS6 we started …

Use SCL packages without bash

The recommended way to run SCL packages is by using the scl command and starting a new session like this:

Installing Ruby 1.9.3 on CentOS 6

The easiest way to do this is to use Software Collections.

Dell XPS13/XPS15 white noise via audio

Just a quick post to make a copy of a script that I'd rather not lose. By default, the XPS15 has a fairly quiet white noise hiss when using headphones without any sound playing. Someone linked me to …

Using a custom startup script for xmonad

As lightdm doesn't call .xinitrc, I needed to find another way to start things like trayer. The easiest way is to create a file called .start-xmonad in your home directory, and point the lightdm

Start PolicyKit on Ubuntu

As I run vanilla xmonad, I don't get nice things started for me when I boot up. Though I normally install packages with dpkg -i package.deb, sometimes I want to use the software centre and I need to …

Basic iptables rules

This post is a quick one for me, as I'm sure I'll need these rules again at some point. I'll probably need to mix and match the rules, but these ones should cover most bases.

Building from source

Ever since I first started using Linux, I've been using package managers to manage my system. Coming from a Windows background I wasn't really sure on how compiling from source works, how to …

Keyboard stops working on Ubuntu - slow-keys

Since I started using i3, every now and then it would seem as though my keyboard's stopped working. Usually, I just reboot the machine and it starts working again. This time though, I wanted to try …

Getting Solarized working on Ubuntu

I use Solarized on everything, so when I started using Ubuntu again, not having it on there wasn't really an option. Unforunately, there's no easy way to install it on Ubuntu, it's very much left to …

unetbootin - BOOTMGR Is Missing

I recently spent far longer than I would have liked trying to install xubuntu onto my old Dell Mini 10v. Usually, I'd use unetbootin to create a bootable USB and it'd boot and install fine. However, …