Keyboard stops working on Ubuntu – slow-keys

This article was published 6 years ago. Due to the rapidly evolving world of technology, some concepts may no longer be applicable.

Since I started using i3, every now and then it would seem as though my keyboard’s stopped working. Usually, I just reboot the machine and it starts working again. This time though, I wanted to try and work out why it happened.

I noticed that if I held a key down, it would actually output it to the screen. A bit of searching later, and it seems as though I’d accidentally managed to enable slow-keys by holding down shift for 8 seconds.

The majority of the solutions involve opening up keyboard preferences and disabling it. Unforunately, I don’t have a menu to find this in so I needed to disable it via the command line. Fortunately, it’s quite easy to do.

# Install xkbset for managing keyboard options
sudo apt-get install xkbset
# Disable slow-keys
xkbset -sl
# Disable accessibility so slow-keys won't turn back on
xkbset -a

Thoughts on this post

aaaa 2013-08-03


Omari Celestine 2013-09-27

Thank you very much. This was annoying me very much.

arcticblu3 2013-09-29

awesome. this completely fixed the issue I was having when the keyboard would stop responding randomly while I was typing.
I guess I pause with the shift key held down…

Günther 2013-11-03

Thanks a lot! You’ve saved me a lot of trouble! :)

albert_it 2013-11-05

Works great ;) Thank you!

Joseph 2013-11-08


Adam 2014-06-16

Simple and easy solution. I knew there had to be one. Thanks.

heiko 2014-12-14

Great advice. I use kubuntu 1404, slow keys disabled, yet still had that sluggish behavior. This worked quite well. So somehow slow keys have been enabled but not been shown as such.

Luke Kendall 2016-03-08

I just had the same thing happen, but a different cause. Firefox had linked up with the “save as” panel open (in a developer release, Ubuntu 16.04). Nothing worked to produce keyboard input until I forced a quit of Firefox.

summaries 2016-03-24

THANK you ! it worked

Garry Schindler 2017-04-01

A big thanks! I switched to linux mint a year back so its a newer OS to me. Had that elusive problem too. Thanks for posting info on it. Not something I ever ran across using Windows. LOL

fabiano 2017-05-05

post still working …. tks (Lubuntu Linux Laptop 4.4.0-77-generic #98-Ubuntu SMP Wed Apr 26 08:33:44 UTC 2017 i686 i686 i686 GNU/Linux ), regards, fabiano

Leave a comment?

Leave a Reply to aaaa Cancel reply